How to install a specific version of a package with pip?


Question

Possible Duplicate:
Installing specific package versions with Pip

I am a bit new to pip install and virtualenv in general.

I have setup an virtualenv on my server as well as on my local dev environment.

On the server the package django_modeltranslation-0.4.0_beta2 works perfectly fine.

However on my local machine django_modeltranslation-0.5.0-alpha doesn't seem to work well at all.

I usually simply install it in virtual-env like this:

$ source bin/active
(env)$ pip install django_modeltranslation

This gets the latest version though, which now for the first time causes issues working with latest version.

So I have uninstalled the version 5 alpha like this:

(env)$ pip uninstall django_modeltranslation

But now I don't know how I could get the working version 0.4.0 Beta again. I tried this but it couldn't find it:

(env)$ pip install django_modeltranslation-0.4.0_beta2
Downloading/unpacking django-modeltranslation-0.4.0-beta2
  Could not find any downloads that satisfy the requirement django-modeltranslation-0.4.0-beta2
No distributions at all found for django-modeltranslation-0.4.0-beta2

I think there must be a way, since that is the whole point of using virtual env.

1
118
5/23/2017 12:18:18 PM

Accepted Answer

Use ==:

pip install django_modeltranslation==0.4.0-beta2
210
12/17/2012 3:27:01 PM

Licensed under: CC-BY-SA with attribution
Not affiliated with: Stack Overflow
Icon